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Excel 2: Formulas, Charts, & More 

Class Guide 
Instructor: Susan Jerger  

 

Part 1: Excel 1 Recap 
1.1 Formatting Refresher 

   Below is a picture of the Home tab of the Ribbon which contains most, but not all, of the 

features we’ll go over in class today.   

 

Class Exercise: On the Grand Opening Contacts spreadsheet in Excel2Class 

Spreadsheets.xlsx... 

1. Spruce up the spreadsheet with colors and borders 

2. Merge & Center the “Grand Opening Contact List” across the top of the table 

3. Widen columns A, B, C, and H 

 

Part 2: Sorting & Filtering 
2.1 Sorting 

   You can easily sort your data alphabetically, chronologically, or numerically…and even by 

color.  Sorting can be Ascending (A-Z) or Descending (Z-A).  If you have a Header Row (a top 

row that labels the data of your table), it is a good idea to format this row to stand out from your 

actual data. 

 

Class Exercise: On Grand Opening Contacts… 

1. Place the cell pointer on one of the last names in column A. 

2. Click on Sort & Filter and then 

  

Class Exercise: On Grand Opening Contacts… 

1. Place the cell pointer on any cell within A4 to K26 

2. Click on Sort & FilterCustom Sort 

3. Choose to sort by Last Name and then First Name 

and then Business on the window that pops up. 

4. Click OK. 

 

Class Exercise: On Grand Opening Contacts… 

1. Change the background color of 5 Last Name cells (that are not all next to each other 

alphabetically) and then click on just one cell in your table 

2. Click on Sort & FilterCustom Sort 

Font Borders
  

Fill Color Vertical Alignment 

Horizontal Alignment % formatting 

AutoSum Wrap Text 

Merge & Center 
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3. Add another level and make sure it is at the top.  Sort it by Last Name 

and sort on Color. Choose the Order and click OK 

NOTE: You can also sort horizontally if needed by clicking on Options in the Sort 

box and then choosing the Sort left to right orientation. 

 

2.2 Filtering 

   Filtering is a quick and easy way to hide data so that you can see only the relevant data you 

need.  It is a cinch to turn off and on. 

 

Class Exercise: On Grand Opening Contacts… 

Place the cell pointer on any cell within A4 to K26 

1. Click on Sort & FilterFilter 

2. On the spreadsheet, click on the down arrow to the right of City 

and select only Greenwood to limit your list. 

3. Click OK 

To turn off filtering, simply click on Sort & FilterFilter 

 

 

Part 3: Data Validation 
3.1 Dropdown Lists 

   Dropdown lists can be a great help if you want to make sure only certain data is entered into 

a field. There are a couple ways to create a dropdown list: type in the values yourself or use a 

preexisting table. 

 

Class Exercise: On Grand Opening Contacts… 

1. Highlight cells H4 to H26 

2. Click on the Data tab and then Data Validation  Data Validation 

3. Under Allow, click the dropdown arrow and choose List 

4. Click the Collapse Dialog button and go to the Cities sheet 

5. Highlight A1 to A4 and click the Collapse Dialog button 

6. Click OK 

7. On the Grand Opening Contacts sheet, locate the cells in 

Column H that have “New Whiteland” and change those 

cities to Whiteland using the dropdown list 

8. Try typing “Indy” in a cell that has Indianapolis and see what 

happens 

 

Part 4: “Official” Tables 
4.1 Format as Table 

   To make life easier you can “officially” mark your table as a Table in Excel. This will help down 

the road if you add in new rows, delete columns, etc. Also, you won’t have to worry as much 

about changing cell references in Functions in the future. 

 

Class Exercise: On Grand Opening Contacts… 

1. Place the cell pointer on any cell within A4 to K26 

2. Click the Insert tab of the Ribbon and then Table 

3. Click OK on the little Create Table window that pops up (or change the cell references if 

they are incorrect first) 
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4. Change the default name of your table by going to the Table Tools tab and looking at 

the Table Name on the far left. Erase the current name and type in “Contacts”  

5. Press Enter 

 

 

Part 5: Altering Your View 
5.1 Freezing Panes 

   You can freeze panes—sections of the spreadsheet—so you can easily view them even when 

you scroll up and down/left and right.  Freezing Panes does not affect how your spreadsheet 

prints. 

 

Class Exercise: On Grand Opening Contacts… 

1. Click on cell A4 

2. Click on the View tab of the Ribbon 

3. Click on Freeze PanesFreeze Panes 

4. Now scroll down and see if Rows 1-3 stay in place 

Click on Freeze PanesUnFreeze Panes to turn this feature off 

 

 

Part 6: Formulas & Functions 
6.1 Formula Basics 

   Formulas are equations that perform calculations on values in your spreadsheet and always 

start with an equal sign (=).  Here are the symbols/operators for simple calculations: 

+ Addition  - Subtraction  * Multiplication  / Division 

Ordering = Excel calculates from left-to-right with multiplication and division always completed 

first [use () to change this order] 

Copying Formulas = You can copy & paste or use AutoFill to easily copy formulas from cell to 

cell. 

 

6.2 Function Basics 

  Functions are prewritten formulas—you just need to supply the value(s) and not the 

operator(s).  The same rules for formulas apply to functions.  Some other info: 

 You can calculate ranges of cells using the colon (:) 

 You can use a comma (,) to separate cells you want to include that are not in a range 

 If you don’t highlight what cells you want to include in a function, Excel automatically 

looks above the cell you’re in to locate numbers.  If nothing is there, it will look to the left 

then the right. 

 

Class Exercise: AutoSum      is the function we used in Excel 1.  On the Widget Sales Data 

spreadsheet… 

1. Select Row 15 and click Wrap Text in the Ribbon 

2. Click on cell B13 

3. Click on the AutoSum shortcut at the top right 

4. Click the checkmark at the top or press Enter 

5. Tally the rest of the months as well as column N using AutoSum (and AutoFill)   

6. Use AutoSum in cells N4 to N12 to tally each widget type 

 

NOTE: If ##### appears in a cell, widen the column so the number will fit.   
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HINT: You can automatically widen all columns in your spreadsheet.  Here’s how: 

 Click on the empty gray rectangle to the left of column A 

 Click on FormatAutofit Column Width 

 

6.3 MAX, AVERAGE, & Percentage 

  We will explore other functions (there are hundreds of them!) as well as 

create a percentage formula.  You can get to all functions in Excel by clicking 

on AutoSumMore Functions or by clicking on the Formulas tab of the Ribbon 

(be sure to not be on a cell that has a function in it when you do this). 

 

Class Exercise: On Widget Sales Data… 

1. Put the cell pointer on B16 

2. Click on the arrow next to AutoSum near the top 

3. Find the MAX listing and click on it 

4. Next, a formula will show up in your spreadsheet with cells Excel thinks you want to use 

5. Change the cell references to B4 through M4 by typing that in or highlighting those cells 

6. Click the checkmark or press Enter 

7. Calculate the MAX monthly sales figure for the other colors plus the Total using Autofill 

 

Class Exercise: On Widget Sales Data… 

1. Put the cell pointer on C16 

2. Click on the arrow next to AutoSum near the top 

3. Find the AVERAGE listing and click on it 

4. Next, a formula will show up in your spreadsheet with cells Excel thinks you want to 

average.  They are not the correct ones, so highlight cells B4 through M4. 

5. Press Enter or click the checkmark 

6. Calculate the AVERAGE number for the other colors plus the Total using Autofill 

 

Class Exercise: On Widget Sales Data, we will figure each color’s Average Monthly Sales 

percentage of the Average Monthly Total. 
1. Put the cell pointer on D16 

2. Type =c16/c25 and press Enter 

3. Format the result to a 

percentage by clicking on the 

%  in the Number area of the 

Home tab ribbon 

4. Try to copy this formula into cell 

D17.  You will notice that this will 

not work since Excel will change 

the Relative Reference from cell 

C25 down to C26 which is blank.  

To get copying and pasting to 

work, we’ll redo our percentage 

formula so that the reference to 

C25 is partially ABSOLUTE instead 

of all RELATIVE. 

5. Go back to cell D16 and type =c16/c$25 
6. Copy and paste the formula into cells D17 through D24 

There may be occasions when you need an Absolute Cell 
Reference (or a combination of Relative and Absolute) so that 
one or more of the cells in your formula or function never 
change…or only change by column or row.  “$” symbols indicate 
an absolute reference.   

Example When copied… 

=a4/$b$3 A4 can change; B3 will 
never change 

=a4/$b3 A4 can change; Column B 
will never change but Row 
3 can 

=a4/b$3 A4 can change; Column B 
can change but Row 3 will 
not 
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6.4 COUNT 

  COUNT is one function from a group called Count Functions. Its goal is to add up the cells in a 

selected range that contain numbers (not text…just numbers).   

 

Class Exercise: On the Widget Orders spreadsheet… 

1. Click on cell B16 

2. Either type =count(b4:b10) or click on the arrow next to AutoSum and choose Count 

Numbers (and then highlight B4:B10) 

3. Use AutoFill on cells C16 to E16. 

 

6.5 COUNTIF 

  COUNTIF is a statistical function you can use to count the number of cells that meet a 

criterion. It is typed as =COUNTIF(range, criteria). 

 

Class Exercise: On Cities and Grand Opening Contacts… 

1. Go to the Cities sheet first and copy cells A1 to A4 

2. Go to Grand Opening Contacts and paste the cells starting at M4; widen column M 

3. In cell N4 type =countif(h:h,m4) and click the checkmark in the Formula Bar (the H:H 

means that the entire column H is selected which will be helpful if additional rows are 

added to the table later). 

4. Use Autofill to copy the function from cell N4 to N5-N7 

5. Change some of the cities in column H and see who the numbers in column N change 

 

 

 

Part 7: Charts…As Easy As Pie (and Line and Bar…) 
7.1 Charts  

   It is super easy to make charts of a table in Excel 

using the Insert tab menu.  The exercise below will 

demonstrate this feature.  

 

 Class Exercise: Back on the Widget Sales Data sheet… 

1. Highlight the data range A15 to B24 for our chart. 

2. Click on the Insert tab and then Column. Choose the first 3-D Column from the 

dropdown list. 

3. Notice that three new Chart Tools tabs appear above the Ribbon.  These will help you 

customize your chart. 

 

 

 

 

 

4. Click on the Layout tab.  Use the Chart Title, Legend, and Data Labels menu to change 

your chart if you would like. 

5. Next, click on the Move Chart option on the Design tab which will give you the option to 

place your chart in a new worksheet.  Let’s do that!  
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Part 8: Help! 
8.1 MS Office Help 

Excel has a help feature that can aid you in refreshing your memory on certain tasks or 

by even learning new tasks.  Help can be reached by clicking the Question mark in the 

upper right hand corner.  You will most likely be directed to Office.com’s online help, but 

there is an offline version if needed.  

 

8.2 Additional Help 

  Below are some websites that might be of help to you: 

 

www.greenwoodlibrary.us/computer-class - Lists all of the library’s computer classes and 

includes the Excel guides and class spreadsheets. 

 

Lynda.com (via www.greenwoodlibrary.us/online-databases - scroll down 

to lynda.com to create a free account using your GPL Evergreen Indiana 

library card) - Learn from over 3,000 courses on a variety of topics 

including business, web development, multimedia skills, Microsoft Office Excel, and coding to 

name a few. The courses are on demand and delivered by expert instructors. 

www.gcflearnfree.org - A great collection of tutorials on a wide array of subjects including 

Microsoft Excel 2000-2016. 

www.free-training-tutorial.com – Free tutorial videos on Excel tasks (just be wary of clicking on 

the ads) 

http://spreadsheets.about.com/ 

www.customguide.com/cheat-sheets/ - Free cheat sheets for most Office programs  

www.google.com/work/apps/business/products/sheets/ - You can use Google Sheets for free 

(after creating a Google account) to practice many of the Excel features we’ve used today. 

You can also find help by searching for the function you want to use or the problem you’re 

having using your favorite search engine. 

 

Thank you for coming! 
Please fill out a program survey before leaving. 

http://www.greenwoodlibrary.us/programming-survey 
or go to www.greenwoodlibrary.us Services & Programs  Adult Programming Survey  

*not Computer Survey* 

 

Program Attended: Excel 2 
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