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Excel 3: Linking, PivotTables, vLookup, & 

Macros Class Guide 
Instructor: Susan Jerger  

 

Part 1: Name That Cell/Those Cells 
1.1 Naming 

   You can name a cell or a group of cells in your spreadsheet which can facilitate using 

functions. 

 

Class Exercise: Open the Excel3ClassSpreadsheets workbook and use the vLOOKUP sheet… 

1. Highlight cells A7-A42 

2. Go to the Name box (to the left of the Formula Bar) and type SharePrices 

3. Press Enter 

 

NOTE: Not sure what’s been named on a spreadsheet?  You can see on the named areas by 

going to the Formulas tab and clicking on Name Manager. 

 

 

Part 2: vLOOKUP Function & Nesting 
2.1 vLOOKUP 

   The “v” in vLOOKUP stands for vertical.  You can use this function to look up a value in a 

predefined range and return a corresponding value.  Here is the syntax: 

 

=vlookup(lookup_value,table_array,col_index_num,[rangle_lookup]) 
 

From http://office.microsoft.com/en-us/excel-help/vlookup-function-HP010343011.aspx: 

 

lookup_value – Required. The value to search in the first column of the table or range. 

The lookup_value argument can be a value or a reference. If the value you supply for the 

lookup_value argument is smaller than the smallest value in the first column of 

the table_array argument, VLOOKUP returns the #N/A error value.  

 

table_array – Required. The range of cells that contains the data. You can use a reference to a 

range (for example, A2:D8), or a range name. The values in the first column of table_array are 

the values searched bylookup_value. These values can be text, numbers, or logical values. 

Uppercase and lowercase text are equivalent. 

 

col_index_num - Required. The column number in the table_array argument from which the 

matching value must be returned. A col_index_num argument of 1 returns the value in the first 

column in table_array; acol_index_num of 2 returns the value in the second column 

in table_array, and so on. 

 

range_lookup – Optional. A logical value that specifies whether you want VLOOKUP to find an 

exact match (FALSE) or an approximate match (TRUE): 

http://office.microsoft.com/en-us/excel-help/vlookup-function-HP010343011.aspx
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If range_lookup is either TRUE or is omitted, an exact or approximate match is returned. If 

an exact match is not found, the next largest value that is less than lookup_value is 

returned. This works best if values are in ascending order. 

 
Class Exercise: On the vLookup worksheet… 

1. Determine the maximum Share Price: go to B3 and type =max( 

2. Then go to the Formulas tab and click on Use in Formula 

3. From the dropdown list, choose SharePrices and type ) and Enter to finish 

the formula 

4. Use Format Painter to format cell B3 like the other share prices if necessary 

5. Go to B4 and use the vlookup function to return the maximum share price’s date:  

=vlookup(B3,A7:B42,2,FALSE) 
6. Be sure the press Enter or click the checkmark when done inputting the function 

7. Format B4 for short date if it’s not already set that way 

 

2.2 Nesting Functions 

  You can nest functions to make your spreadsheets neater and/or more compact. You only 

use “=” at the beginning. 

 

Class Exercise: On the vLookup worksheet… 

1. Delete row 3 and notice that the vlookup function returns an error…that’s ok! 

2. Double-click on the function that is now in cell B3 

3. Delete #REF! and replace it with max(SharePrices) 
4. The new nested functions will look like this: 

=VLOOKUP(MAX(SharePrices),A6:B41,2,FALSE) 
5. Be sure to press Enter or click the checkmark when done inputting the function 

 

NOTE: If your data is set-up horizontally you can use the HLOOKUP function. 

 

 

Part 3: Tables Revisited 
3.1 Format as Table 

  To make life easier you can official mark your table as a table in Excel. This will help down the 

road if you add in new rows, delete columns, etc…you won’t have to worry as much about 

changing cell references. 

 

Class Exercise: On the PivotTable Data worksheet… 

1. Click somewhere between cell A3 and D68 

2. On the Insert tab of the Ribbon, click Table 

3. On the Create Table window, verify that A3 to D68 are selected and click OK 

4. On the Table Tools Design tab, change the Table Name to CompanySales on the far left 
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Part 4: PivotTables, Slicers, & PivotCharts 
4.1 PivotTable Basics 

 PivotTable = A feature that enables you to summarize and analyze data in lists and tables. 

Pivot tables are called such because you can quickly rearrange the position of pivot table 

fields to give you a different view of the table (from 

http://www.cs.rtu.lv/PharePub/Microsoft%20Access%2097%20Quick%20Reference/htm/ch09.htm). 

 

Class Exercise: On the PivotTableData worksheet… 

1. Place the cell pointer somewhere in the sales table 

2. Click on the Insert tab on the Ribbon and then choose 

PivotTablePivotTable 

3. The Create PivotTable window pops up; verify that the Table/Range is 

set to CompanySales and click OK  

4. You will be taken to a new worksheet for your PivotTable 

5. The PivotTable Field List should appear on the right.  Choose Region 

(as Rows) and Sales Total (as Values). Sales Totals may 

default to Count.  Should this happen, in the Values box, 

left click on Count of Sales.  Then choose Value Field 

Settings. Click on Sum  

6. Next click on the Show Values As tab and then Number 

Format at the bottom of that box.  Format this field as 

Currency and do OK twice to return 

7. Take out Region and add in Salesperson.  Change value to the 

Max of Sales Total   

8. Go back to the PivotTable Data sheet and type “12000” in D9 

and type Enter 

9. Go back to Sheet1 and click on Refresh on the PivotTable 

ToolsOptions tab 

NOTE: If you ever click off of the PivotTable, you can always get the 

PivotTable Tools tabs to appear by clicking back on the table. 

 

4.2 Slicers 

 Slicers are new in 2010. They are easy-to-use filtering components that contain a set of buttons 

that enable you to quickly filter the data in a PivotTable report, without the need to open drop-

down lists to find the items that you want to filter (from support.office.com).  

 

Class Exercise: On the Sheet1 worksheet… 

1. Make sure the active cell is in the PivotTable so you’ll see the PivotTable Tools tabs 

2. On the Options tab click Insert Slicer 

3. Select Region in the dialog box and click OK 

4. Click on the different Region buttons to see the Salespeople for one region at a time 

5. You can select more than one by holding down the CTRL key and clicking the ones you 

want 

 

NOTE: Starting with Excel 2013, you can use slicers with named tables without having to create 

a PivotTable first. 

 

  

http://www.cs.rtu.lv/PharePub/Microsoft%20Access%2097%20Quick%20Reference/htm/ch09.htm
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4.3 PivotCharts 

 PivotCharts are super easy to insert and change to suit what data you’d like to display.  

 

Class Exercise: On the Sheet1 worksheet… 

1. Make sure the active cell is in the PivotTable so you’ll see the PivotTable Tools tabs 

2. On the Option tab, click on PivotChart 

3. Choose a Column chart and click OK 

4. If you can’t see the PivotTable and/or Slicer, left click and drag the PivotChart and Slicer 

to better locations on the sheet 

5. Click on the different Region buttons of the Slicer to see how the PivotChart changes 

 

 

Part 5: Manipulating Sheets 
5.1 Inserting, Renaming, and Linking  

Insert a Sheet 

 Click on InsertInsert Sheet (you can click and drag worksheets into whatever order 

you prefer) 

 OR click on the Insert Sheet button near the 

tabs at the bottom 

Renaming Sheets 

  You can change the generic sheet names “Sheet1, Sheet2, etc.” to something more 

meaningful: 

 Right-clicking on the current sheet name 

 Select Rename 

 Type in the new name and hit Enter 

Moving Sheets 

  You can easily rearrange your sheets by clicking & dragging the sheet tab to the desired 

location 

Link Sheets 

  It can be helpful to connect different sheets in order to perform calculations or compare data 

 Click on the blank cell you want to link 

 Type = and click on the worksheet that has the cell you want to copy 

 Click on the cell you want to link and press Enter 

Toggling Between Sheets 

  Since you can have numerous sheets it can sometimes be hard to view the tabs all at once or 

just to get to the next one in line.  You can toggle using the keyboard shortcuts:  CTRL+Page Up 

and CTRL+Page Down. 

Copying Sheets 

  You can easily copy a sheet: 

 Right-click on the tab you want to copy 

 Click on Move or Copy 

 In the window that pops up, checkmark the Create a Copy box and click OK 

Coloring Tabs 

  You can color code your sheet tabs if needed: 

 Right-click on the tab you want to color 

 Click on Tab Color and choose a color 

 If you can’t see the color change, click on a different tab to see it 
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Hiding/Unhiding Sheets 

  You can hide sheets from view: 

 Right-click on the tab you want to hide 

 Click on Hide 

To unhide, right-click on any tab and click on the sheet to unhide and click OK. 

 

Class Exercise: Open the SalesSheets workbook… 

1. Insert a new worksheet and rename it 1st Quarter Sales 

2. Reorder the worksheets so that they are in chronological order but with 1st Quarter Sales 

first. 

3. Create the table below on the 1st Quarter Sales sheet: 

 

 

 

 

 

 

 

 

 

4. Link ALL the sales figures for each month into the correct cell on the 1st Quarter Sales 

sheet.  

For instance: Click on 1st Quarter Sales’ cell B4 and type =.  Go to January’s sheet and 

click on Cell B4 and press Enter. Do Autofill to copy and paste the linking formula for 

the other colors 

5. Use AutoSum to tally all the color totals and all the monthly totals for the quarter.  When 

you’re all finished, it should look something like this: 

6. Change all four tabs to different colors. 
 

 

Part 6: Find & Replace Almost Anything 
6.1 Find and Replace 

  You can pull up the Find and Replace window in Excel by typing CTRL+F.  Can’t remember 

where you typed something?  Do a Find for it within a worksheet or the entire workbook.  Need 

to replace some information?  Do a Find and Replace (again within the worksheet or the entire 

workbook). 
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Class Exercise: In SalesSheets… 

1. Type CTRL+F and click on the 

Replace tab and then Options 

2. Find all the instances of the word 

Brown and Replace them with the 

word Gold within the Workbook 

3. Click Replace All  

4. Click OK and then Close 

5. Close and save the file 

NOTE: You can also access Find and 

Replace from Find & Select on the right side of the Home tab. 

 

 

Part 7: Split Screen 
7.1 Splitting screens 

  You can easily split a worksheet into two panes so you can compare data from two different 

parts of your worksheet that are far away. You can edit either pane and changes will update in 

the worksheet. 

 

Class Exercise: On the PivotTable Data worksheet of the Excel3ClassSpreadsheets 

workbook… 

1. Place the cell pointer in A10 

2. On the View tab click Split 

3. The worksheet is now split; scroll through the top and bottom panes 

4. Turn off the Split setting simply by clicking on the Split button again. 

 

 

Part 8: Macros 
8.1 Creating a Macro 

  A macro is a recording of tasks…a way to automate repetitive tasks in your workbook.  Excel 

macros are written in Excel VBA (Visual Basic for Applications).  For simple macros you don’t 

actually need to know Excel VBA. 

 

Since macros involve coding, a file with macros needs to be saved as “Excel Macro-Enabled 

Workbook” for the macros to work later on. 

 

And, also since macros involve coding, they can be used to spread malicious codes so only run 

macros from people you trust. 

 

You can record a macro from View tab. However, if you want to see more macro options 

easily, you want the Developer tab to be accessible. If you don’t have a Developer tab in the 

Ribbon, click on File  Options  Customize Ribbon  check Developer on the right.  Click OK. 

 

NOTE: Once a macro runs, you cannot use the Undo command to, well, undo the macro’s 

actions.  
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Class Exercise: On the PivotTable Data worksheet… 

We are going to create a macro to automatically sort our table for us. 

1. Click the Developer tab 

2. Click Record Macro. On the Record Macro window, type in 

the name SortRegionSalesperson 

3. Make “Ctrl+Shift+S” the shortcut key (you are not required to 

insert a shortcut) 

4. Click OK 

5. Click on A4  

6. Go to the Home tab if not there already and click on Sort 

& FilterCustom Sort 

7. Sort by Region and then Salesperson and click OK 

8. Click on the Developer tab and click Stop Recording 

9. Test the macro by sorting the table by Date and then 

typing CTRL+SHIFT+S 

10. Resort again by Date 

11. Insert a Rounded Rectangle shape (from the Insert tab) to create a button to the top 

right of the table 

12. Type “Sort by Region & Salesperson” in the rectangle 

13. Right-click on the rectangle and choose Assign Macro 

14. Choose the macro you’ve just made and click OK 

15. Click the button and watch the macro run! 

16. Type ALT+F11 to open the VBA 

editor 

17. Open the Modules folder to 

get to Module 1 to take a look 

at the macro’s code 

18. When done, click the top x in 

the VBA window to exit 

19. Back in Excel do Save As and 

save this file as an Excel 

Macro-Enabled Workbook so 

the macro will work in the 

future 

20. Close the file 

 

 

Part 9: Help!  
9.1 MS Office Help 

Excel has a help feature that can aid you in refreshing your memory on certain tasks or 

by even learning new tasks.  Help can be reached by clicking the Question mark in the 

upper right hand corner.  You will most likely be directed to Office.com’s online help, but 

there is an offline version if needed.  
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9.2 Additional Help 

  Below are some websites that might be of help to you: 

 

www.greenwoodlibrary.us/computer-class - Lists all of the library’s computer classes and 

includes the Excel guides and class spreadsheets. 

 

Lynda.com (via www.greenwoodlibrary.us/online-databases - scroll down 

to lynda.com to create a free account using your GPL Evergreen Indiana 

library card) - Learn from over 3,000 courses on a variety of topics 

including business, web development, multimedia skills, Microsoft Office Excel, and coding to 

name a few. The courses are on demand and delivered by expert instructors. 

www.gcflearnfree.org - A great collection of tutorials on a wide array of subjects including 

Microsoft Excel 2000-2016. 

www.free-training-tutorial.com – Free tutorial videos on Excel tasks (just be wary of clicking on 

the ads) 

http://spreadsheets.about.com/ 

www.customguide.com/cheat-sheets/ - Free cheat sheets for most Office programs  

www.google.com/work/apps/business/products/sheets/ - You can use Google Sheets for free 

(after creating a Google account) to practice many of the Excel features we’ve used today. 

You can also find help by searching for the function you want to use or the problem you’re 

having using your favorite search engine. 

 

Thank you for coming! 
Please fill out a program survey before leaving. 

http://www.greenwoodlibrary.us/programming-survey 
or go to www.greenwoodlibrary.us Services & Programs  Adult Programming Survey  

*not Computer Survey* 

 

Program Attended: Excel 3 
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