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Excel 3: Linking, PivotTables, vLookup, &
Macros Class Guide

Instructor: Susan Jerger

Part 1: Name That Cell/Those Cells
1.1 Naming

You can name a cell or a group of cells in your spreadsheet which can facilitate using
functions.

@ Class Exercise: Open the Excel3ClassSpreadsheets workbook and use the vLOOKUP sheet ...
1. Highlight cells A7-A42
2. Go to the Name box (to the left of the Formula Bar) and type SharePrices (do not use
spaces when naming sections of your spreadsheet)
3. Press Enter

NOTE: Not sure what's been named on a spreadsheet? You can see on the named areas by
going to the Formulas tab and clicking on Name Manager.

Part 2: vLOOKUP Function & Nesting
2.1 vLOOKUP

The “v” in vLOOKUP stands for vertical. You can use this function to look up a value in a
predefined range and return a corresponding value. Here is the syntax:

=vlookup(lookup_value, table_array,col_index_num,[rangle_lookup])

From http://office.microsoft.com/en-us/excel-help/viookup-function-HP01034301 1.aspx:

lookup_value - Required. The value to search in the first column of the table or range.
The lookup_value argument can be a value or a reference. If the value you supply for the
lookup_value argument is smaller than the smallest value in the first column of

the table_array argument, VLOOKUP returns the #N/A error value.

table_array — Required. The range of cells that contains the data. You can use a reference to a
range (for example, A2:D8), or a range name. The values in the first column of table_array are
the values searched bylookup_value. These values can be text, numbers, or logical values.
Uppercase and lowercase text are equivalent.

col_index_num - Required. The column number in the table_array argument from which the
matching value must be returned. A col_index_num argument of 1 returns the value in the first
column in table_array; acol_index_num of 2 returns the value in the second column

in table_array, and so on.

range_lookup — Optional. A logical value that specifies whether you want VLOOKUP to find an
exact match (FALSE) or an approximate match (TRUE):
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If range_lookup is either TRUE or is omitted, an exact or approximate match is returned. If
an exact match is not found, the next largest value that is less than lookup_value is
returned. This works best if values are in ascending order.

@ Class Exercise: On the vLookup worksheet... L Use in Formula =
. Determine the maximum Share Price: go to B3 and Ty% horePrices

Then go to the Formulas tab and click on Use in Formula Paste Names...
From the dropdown list, choose SharePrices and type ) and Enter to finish

the formula

Use Format Painter on the Home tab to format cell B3 like the other share prices if
necessary

5. Go to B4 and use the vlookup function to return the maximum share price's date:

=vlookup(B3,A7:B42,2,FALSE)

6. Be sure the press Enter or click the checkmark when done inputting the function
7. Format B4 for short date if it's not already set that way

W -

»

2.2 Nesting Functions
You can nest functions to make your spreadsheets neater and/or more compact. You only
use “=" at the beginning.

Class Exercise: On the vLookup worksheet...
@ 1. Delete row 3 and notice that the vlookup function returns an error...that's ok!
2. Double-click on the function that is now in cell B3
3. Delete #REF! and replace it with max(SharePrices)
4. The new nested functions will look like this:

=VLOOKUP(MAX(SharePrices),A6:B41,2,FALSE)

5. Be sure to press Enter or click the checkmark when done inputting the function

NOTE: If your data is set-up horizontally you can use the HLOOKUP function.

Part 3: Tables Revisited
3.1 Format as Table

To make life easier you can official mark your table as a table in Excel. This will help down the
road if you add in new rows, delete columns, etc...you won't have to worry as much about
changing cell references.

@ Class Exercise: On the PivotTable Data worksheet...
1. Click somewhere between cell A3 and Dé8
2. On the Insert tab of the Ribbon, click Table
3. On the Create Table window, verify that A3 to Dé8 are selected and click OK
4. On the Table Tools Design tab, change the Table Name to CompanySales on the far left
and type Enter.
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Part 4: PivotTables, Slicers, & PivotCharts

4.1 PivotTable Basics

PivotTable = A feature that enables you to summarize and analyze data in lists and tables.
Pivot tables are called such because you can quickly rearrange the position of pivot table

fields to give you a different view of the table (from
http://www.cs.rtu.lv/PharePub /Microsoft%20Access%2097%20Quick%20Reference /htm/ch09.htm).

@ Class Exercise: On the PivotTableData worksheet... 1= ? B
1. Place the cell pointer somewhere in the sales table /7,,%53“ e

2. Click on the Insert tab on the Ribbon and then choose PivotTable on the left e

3. The Create PivotTable window pops up; verify that the Table/Range is set to
CompanySales and click OK B [T v

4. You will be taken to a new worksheet for your PivotTable -

-

5. The PivotTable Field List should appear on the right. Choose Region = .
(as Rows) and Sales Total (as Values). Sales Totals may default to PivotTable Fields  ~
Count. Should this happen, in the Values box, left click on Count Of\ Chesseficldsto add to report: -
Sales. Then choose Value Field Settings. Click on Sum Search o
6. Next click on Number Format at the bottom of that box. Format this |
field as Currency and do OK twice to return Region

a. Take out Region and add in Salesperson. Change value to 2:':::;'”
the Max of Sales Total

7. Go back to the PivotTable Data sheet and type “12000” irT\ ViueField Sttings T X
D9 and type Enter

8. Go back to Sheetl and click on Refresh on the PivoiTable (o stom ame: [MaxorSales Tofal
Tools=> Analyze tab Summartze Valies By [Show Yelues s

Source Mame: Sales Total

ummarize value field by

NOTE: If you ever click off of the PivotTable, you can always get hoose the ype of calculation that you want to use to summarize
the PivotTable Tools talbs to appear by clicking back on the table. ?;”"““ selecedfield X
. A\reraie
4.2 Slicers in .
Slicers are easy-to-use filtering components that contain a set of
buttons that enable you to quickly filter the data in a regular table || wumer romat Cancel
or PivotTable, without the need to open drop-down lists to find the —
items that you want to filter (from support.office.com).
=
Class Exercise: On the Sheetl worksheet... . |
@ . Make sure fhe acfive cell is in the PivofTable. On the Insert tab click Slicer——~ Sheer
2. Select Region in the Insert Slicers box and click OK Insert Slicers ;7 %
3. Click on the different Region buttons to see the Salespe for
one region at a time [ Date
+/| Region

4. You can select more than one by holding down the CTRL key (or S
dlesperson

click on the button with 3 checkmarks) \ O] sales Total
Region g

and clicking the ones you want —>
5. Click on the filter + X button to furn off —
filtering.

East
North

South
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4.3 PivotCharts
PivotCharts are super easy to insert and change to suit what data you'd like to display.

Class Exercise: On the Sheet] worksheet...
1. Make sure the active cell is in the PivotTable so you'll see the PivoiTable Tools tabs

2. On the Analyze tab, click on PivotChart
3. Choose a Column chart and click OK —> -
4. If you can't see the PivotTable and/or Slicer, leff click and drag the PivotChart I
and Slicer fo better locations on the sheet PivotChart
5. Click on the different Region buttons of the Slicer to see how the PivotChart
changes

Part 5: Manipulating Sheets
5.1 Inserting, Renaming, and Linking
Insert a Sheet
o Click on Insert->Insert Sheet (you can click and drag worksheets into whatever order
you prefer)
« OR click on the Insert Sheet button near the tabs at the bottom —> i+
Renaming Sheets )
You can change the generic sheet names “Sheetl, Sheet2, etc.” to something more
meaningful:
e Right-clicking on the current sheet name
e Select Rename
e Type in the new name and hit Enter
Moving Sheets
You can easily rearrange your sheets by clicking & dragging the sheet tab to the desired
location
Link Sheets
It can be helpful to connect different sheets in order to perform calculations or compare data
e Click on the blank cell you want to link
e Type = and click on the worksheet that has the cell you want to copy
e Click on the cell you want to link and press Enter
Toggling Between Sheets
Since you can have numerous sheets it can sometimes be hard to view the tabs all at once or
just to get to the next one in line. You can toggle using the keyboard shortcuts: CTRL+Page Up
and CTRL+Page Down.
Copying Sheets
You can easily copy a sheet:
e Right-click on the tab you want to copy
e Click on Move or Copy
¢ In the window that pops up, checkmark the Create a Copy box and click OK
Coloring Tabs
You can color code your sheet tabs if needed:
e Right-click on the tab you want to color
e Click on Tab Color and choose a color
e |[f you can't see the color change, click on a different tab to see it
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Hiding/Unhiding Sheets
You can hide sheets from view:
e Right-click on the tab you want to hide
e Click on Hide
To unhide, right-click on any tab and click on the sheet to unhide and click OK.

Greenwood Public Library

@ Class Exercise: Open the SalesSheets workbook...
1. Insert a new worksheet and rename it 1st Quarter Sales

2. Reorder the worksheets so that they are in chronological order but with 1st Quarter Sales
first.

3. Create the table below on the 1st Quarter Sales sheet:

A B c D E
1st Quarter Sales

January February March Total

Brown
Green
Red

1
2
3
4
5 Blue
6
7
8
9

4. Link ALL the sales figures for each month into the correct cell on the 1st Quarter Sales
sheet.
For instance: Click on 1st Quarter Sales’ cell B4 and type =. Go to January's sheet and
click on Cell B4 and press Enter. Do Autofill to copy and paste the linking formula for
the other colors
5. Use AutoSum to tally all the color totals and all the monthly totals for the quarter. When
you're all finished, it should look something like this:

A B c D E
1 1st Quarter Sales
2
3
4 January February March Total
5 |Blue $ 1,999.00 | $ 5678.00 | $ 5,699.00 | $13,376.00
6 Brown $ 567.00|% 34.00 | $ 3400 | $ 635.00
7 Green $ 2,467.00 | $ 5,788.00 | $ 5,788.00 | $14,043.00
8 Red $ 67.00 | $ 67.00|$ 134.00|9% 268.00

i /=]

6. Change all four tabs to different colors.
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Part 6: Macros
6.1 Creating a Macro

Greenwood Public Library

A macro is a recording of tasks...a way to automate repetitive tasks in your workbook. Excel
macros are written in Excel VBA (Visual Basic for Applications). For simple macros you don't

actually need to know Excel VBA.

Since macros involve coding, a file with macros needs to be saved as “Excel Macro-Enabled
Workbook” for the macros to work later on.

And, also since macros involve coding, they can be used to spread malicious codes so only run

macros from people you frust.

You can record a macro from View tab. However, if you want to see more macro options
easily, you want the Developer tab to be accessible. If you don't have a Developer tab in the
Ribbon, click on File > Options > Customize Ribbon > check Developer on the right. Click OK.

NOTE: Once a macro runs, you cannot use the Undo command to, well, undo the macro’s

actions.

Class Exercise: On the PivotTable Data worksheet ...
We are going to create a macro to automatically sort our table for us.

1. Click the Developer tab

2. Click Record Macro. On the Record Macro window, type in

the name SortRegionSalesperson

3. Make “Ctrl+Shift+S" the shortcut key (you are not required

to insert a shortcut)
Click OK
Click on A4

oA

Filter-> Custom Sort

7. Sort by Region and then Salesperson

and click OK

8. Click on the Developer tab an

Stop Recording

9. Test the macro by sorting the table by
Date and then typing CTRL+SHIFT+S

10.Resort again by Date

11.Insert a Rounded Rectangle shape
(from the Insert tab) to create a button
to the top right of the table

Go to the Home tab if not there already and click on Sort &

Record Macro ?
Macro name:
SartRegionSalesperson

Shortecut key:
Ctrl=Shift= | 5|

Store macro in:
This Workbook

Description:

dm‘

Sort

4| Add Level || < Delete Level

? X

E@ Copy Level r Options.. My data has headers

Column
Sortby | pe

Sort On
Cell Values

Order
b AtoZ \/

Cell Values ~ AtoZ ~

Cancel

12.Type “Sort by Region & Salesperson” in the rectangle
13.Right-click on the rectangle and choose Assign Macro
14.Choose the macro you've just made and click OK

15.Click the button and watch the macro run!
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16.Type ALT+F11 to open the VBA editor

] 7 Open The MOdUIeS fO|der TO 29 Microsoft Visual Basic for Applications - Excel3ClassSpreadshestsds - [Module] (Code)] - O
ge‘l‘ ‘I'O Module ] 'I'O ‘I'Ol(e a # File Edit View Inset Format Debug Run Tools Addns Window Help -
y H = - @ HEY n 26, Col -
look at the macro’s code =R j F,P e ] Trormegonsaeenereen
(yOU m|gh1‘ need TO doub'e_ = — la; Sub SortRegionsalesperaan()
55 VBAProject (Excel3Class

1423 Microsoft Excel Objects ' Sor
| LEE) Sheet1 (vLOOKUP) '
\ | ~EF] Sheet? (PivotTable T
... 48] ThisWorkbook
Modules

click on Module 1)
18.When done, click the top x

Range ("A4") .Select

in The VBA WindOW 1-0 eX”- T8 Module1 Acti‘;:l::;ﬁizl;.lgizl:ineecs("Pivotl‘able Data") .ListObjects ("xompanysales") .Sort. _
. ActiveWorkbook.Worksheets ("PivotTable Data").ListObjects ("xompanysales").Sort. _
] 9 BOCK |n Excel do sqve As < > SortFields.Add2 Key:=Range ["xompanysales[Region]"), SortOn:=xlSortOnValues _
, Crder:=xlAscending, DataOption:=xlSortNormal
H H prE=eld ﬁ ActiveWorkbook.Worksheets ("PivotTable Data").ListObjects ("xompanysales").Sort
Ond SGVe Thls flle OS Gn EXCeI ,W' SortFields.Add2 Xey:=Range ("xompanysales[Salesperson]”), SortOn:i= _ -
x15S0rtOnValues, Order:=xlAscending, DataCption:=xlSortNormal
chro- Enqbled Workbook Alphabetic WCB‘EDD”ZEdI With ActiveWorkbook.Worksheets ("PivotTable Data").ListObjects ("xompanysales"). _
(Name) Module 1 Sorc
so the macro will work in the eoncase = False
.Orientation = x1TopToBottom
fU'I'Ure .SortMethod = x1Pin¥in
-Rpply
1 End With
20.Close the file i
End Sub

21.Notice there are now two
files with similar names
saved to the desktop. Open
the one with the R

exclamation mark. You will see a security warning. Click Enable content and play around
the macro before closing out of the file.

Part 7: Help!

7.1 MS Office Help
Excel has a help feature that can aid you in refreshing your memory on certain tasks or
by even learning new tasks. Help can be reached by clicking Help in the Ribbon and
then the question mark in the blue circle. You will most likely be directed to Office.com’s

online help, but there is an offline version if needed.

7.2 Additional Help
Below are some websites that might be of help to you:

www.greenwoodlibrary.us/computer-class - Lists all of the library’s computer classes and
includes the Excel guides and class spreadsheets.

Lynda.com (via www.greenwoodlibrary.us/online-databases - scroll down
fo lynda.com to create a free account using your GPL Evergreen Indiana
library card) - Learn from over 3,000 courses on a variety of topics
including business, web development, multimedia skills, Microsoft Office Excel, and coding to
name a few. The courses are on demand and delivered by expert instructors.

www.gcflearnfree.org - A great collection of tutorials on a wide array of subjects including
Microsoft Excel.

www . free-training-tutorial.com - Free tutorial videos on Excel tasks (just be wary of clicking on
the ads)

http://spreadsheets.about.com/
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www.customguide.com/cheat-sheets/ - Free cheat sheets for most Office programs

https://gsuite.google.com/products/sheets/ - You can use Google Sheets for free (after
creating a Google account) to practice many of the Excel features we've used today.

You can also find help by searching for the function you want to use or the problem you're
having using your favorite search engine.

Thank you for coming!

www.greenwoodlibrary.us 8


http://www.customguide.com/cheat-sheets/
https://gsuite.google.com/products/sheets/

